Important
To disable OS X El Capitan's System Integrity Protection (for Mac OS X)
- Restart your Mac.
- As soon as the screen turns black, hold down the command + R keys to access the Recovery Partition.
- When the Apple logo appears on the screen, release the keys.
- Click the Utilities menu and select Terminal.
- Type csrutil disable in the Terminal dialog and press Return. A message will appear to indicate that SIP has been disabled.
- Restart your Mac again for the changes to take effect.
- Run MagicDraw/Cameo Systems Modeler and integrate it with MATLAB.
To use MATLAB® on Mac OS 10.6 (Snow Leopard)
- Install MATLAB®.
- Type the following commands in the terminal to show all files in Finder
• $ defaults write com.apple.finder AppleShowAllFiles TRUE
• $ killall Finder Add the DYLD_LIBRARY_PATH variable to Mac OS:
3.1 Create an empty text file in the /etc folder and name it: launchd.conf.
3.2 Open it with a text editor, for example, TextEdit, and type the following text (no space)setenv DYLD_LIBRARY_PATH /Applications/MATLAB_R2010b.app/bin/maci64:
/Applications/MATLAB_R2010b.app/runtime/maci64
3.3 Save the text file as launchd.conf to the desktop.
3.4 Move the launchd.conf file to the /etc folder.- Create a link to the MATLAB® executable file in /usr/bin if it does not yet exist.
- Call the following commands in the terminal
• $ cd /usr/bin
• $ ln -s /Applications/MATLAB_R2010b.app/bin/matlab matlab - Type the following commands in the terminal to reset Finder
• $ defaults write com.apple.finder AppleShowAllFiles FALSE
• $ killall Finder - Restart Mac OS.
Note
You can also use MATLAB if you are using MagicDraw 18.0 on either Mac OS X 10.10 Yosemite or Mac OS X 10.11 El Capitan by following these steps:
- Disable the SIP (if your Mac is OS X El Capitan) by following the instruction for disabling OS X El Capitan's System Integrity Protection (SIP).
- Install MATLAB ®.
Create the file com.nomagic.magicdraw.simulation.mathengine.plist.
3.1 Create a text file and type the following text.<!DOCTYPE plist PUBLIC"-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Label</key> <string>com.nomagic.magicdraw.simulation.mathengine.plist</string> <key>ProgramArguments</key> <array> <string>sh</string> <string>-c</string> <string> launchctl setenv DYLD_LIBRARY_PATH /Applications/MATLAB_R2012a.app/bin/maci64:/Applications/MATLAB_R2012a.app/runtime/maci64 </string></array><key>RunAtLoad</key><true/></dict></plist>
3.2 Change the /Applications/MATLAB_R2012a.app to your MATLAB directory.
3.3 Save the text file. (If you are using TextEdit, change the file to plain text by clicking Format > Make Plain Text).
3.4 Rename it as com.nomagic.magicdraw.simulation.mathengine.plist.(Note: If you already have the file com.nomagic.magicdraw.simulation.mathengine.plist in /Library/LaunchAgents, add :/Applications/MATLAB_R2012a.app/bin/maci64:/Applications/MATLAB_R2012a.app/runtime/maci64 to your DYLD_LIBRARY_PATH in your com.nomagic.magicdraw.simulation.mathengine.plist. F or example, launchctl setenv DYLD_LIBRARY_PATH <Other_Path>:/Applications/MATLAB_R2012a.app/bin/maci64:/Applications/MATLAB_R2012a.app/runtime/maci64 .)
Create the file com.nomagic.magicdraw.simulation.mathengine.matlab.plist.
4.1 Create a text file and type the following text.<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>Label</key> <string>com.nomagic.magicdraw.simulation.mathengine.matlab.plist</string> <key>ProgramArguments</key> <array> <string>sh</string> <string>-c</string> <string> launchctl setenv MD_MATLAB_MATHENGINE /Applications/MATLAB_R2012a.app/bin/maci64:/Applications/MATLAB_R2012a.app/runtime/maci64 </string></array><key>RunAtLoad</key><true/></dict></plist>
4.2 Change "/Applications/MATLAB_R2012a.app" to your MATLAB directory.
4.3 Save the text file. (If you are using TextEdit, change the file to plain text by clicking Format > Make Plain Text).
4.4 Rename it as com.nomagic.magicdraw.simulation.mathengine.matlab.plist.
- Move the files to /Library/LaunchAgents/ by using the Terminal.
5.1 Run the Terminal.
5.2 Go to the plist files directory.
- $ cd [your plist file directory]
al5.3 Move the plist file to /Library/LaunchAgents/ using the following command
- $ sudo mv com.nomagic.magicdraw.simulation.mathengine.plist /Library/LaunchAgents/
- $ sudo mv com.nomagic.magicdraw.simulation.mathengine.matlab.plist /Library/LaunchAgents/
6. Create a link to the MATLAB® executable file in /usr/bin if it does not exist, by using the following command in the Terminal
- $ cd /usr/bin
- $ sudo ln -s /Applications/MATLAB_R2012a.app/bin/matlab matlab
Note
You need to change the /Applications/MATLAB_R2012a.app in the command line to your MATLAB directory.
7. Restart Mac OS.